Coverart Browser: o plugin que faltava para o Rhythmbox

Atenção: até a presente data, este plugin ainda não é compatível com o Rhythmbox 2.99. Avisaremos quando o port for completo!

Já expressei aqui meu favoritismo pelo Noise (ou Beatbox), player desenvolvido pelo pessoal do elementary para seu novo OS. Uma das principais razões para gostar dele era a simplicidade e boa navegação com capas, coisa que no Rhythmbox só existiu por um curto período de tempo, através de um plugin bem fraquinho, antes de ter seu port para GTK3 completo. Felizmente, nos últimos dias, as coisas mudaram.

Em outras palavras, se você quer ter um player com navegação por capas sem precisar de instalar as bibliotecas à mais que o Noise exigia, existe uma solução! O usuário do github fossfreedomAgustín Carrasco, fizeram o port do antigo plugin para GTK3 nos últimos dois meses  e acrescentaram melhorias significativas para o visualizador de capas. Eu gostei da ideia e contribui com a tradução para Português Brasileiro, que agora está disponível para todos vocês 😀 .

Conheça o Coverart Browser:

O plugin funciona como uma janela dentro do seu Rhythmbox, você pode selecioná-la no painel lateral. Dentro de suas configurações, é possível fazer desta a sua janela inicial do Rhythmbox.

Nas configurações, você também pode escolher o tamanho das capas (!), exibir nome do álbum e do artista em baixo das capas e até cortar ou não os nomes muito grandes com reticências.

A navegação pode ser ordenada de maneira crescente ou decrescente, seguindo os nomes de artistas ou de álbuns. Há também um campo de pesquisa. Clicando no ícone de pesquisa, você poderá especificar seus campos de pesquisa.

Ao clicar em um álbum, suas faixas estarão disponíveis no painel inferior. Com o clique do botão direito, você pode adicionar músicas à sua lista de reprodução.

Busca avançada por Capas:

Sempre que adicionados novos álbuns à sua biblioteca, você pode clicar com o botão direito no ícone do Coverart que ele irá lhe oferecer a opção de buscar por todas as capas. Você pode fazer o mesmo clicando individualmente em cada capa.

Há alguns raros casos em que essa pesquisa pode não ser bem sucedida (o que costuma ocorrer com artistas brasileiros menos famosos), isso é porque que as fontes de pesquisa padrão do plugin podem não ter este álbum cadastrado. Para resolver isso, você pode clicar no álbum e ir ao painel inferior, na aba Capas. Lá você verá uma pesquisa da internet por capas associadas ao álbum. Clique na que se adequar ao seu álbum e ele será carregado para seu navegador.

Instalando o Coverart Browser no seu Rhythmbox:

Se você ficou interessado, siga nossas instruções abaixo para instalar o Coverart Browser no seu Rhythmbox:

git clone https://github.com/fossfreedom/coverart-browser -b master
cd coverart-browser
sh ./install.sh

O primeiro comando baixa o plugin, portanto pode ser executado em qualquer pasta que você quiser. O último comando instala o plugin e exigirá sua senha. Existe a possibilidade de você ainda não possua o “git” instalado. Neste caso, um simples “sudo apt-get install git” deve resolver o problema. Feito tudo isso, basta abrir seu Rhythmbox, ir para o menu Editar—-> Plug-ins. Ative o Coverart Browser e, se desejar, configure suas características em “Preferências”.

Conheça o site do projeto e acompanhe as novidades: https://github.com/fossfreedom/coverart-browser

Qualquer erro referente à tradução, por favor reporte comigo. 😉

Anúncios

11 thoughts on “Coverart Browser: o plugin que faltava para o Rhythmbox

  1. No meu deu o seguinte problema:

    Installing the glib schema (password needed)
    cp: não foi possível criar arquivo comum `/usr/share/glib-2.0/schemas/’: É um diretório
    sudo: glib-compile-schemas: command not found

    • Olá Thiago!

      Isto pode ser consequência da falta de algumas bibliotecas (dependências); Por favor tente adicioná-las com o seguinte comando e depois volte a tentar compilar o coverart-browser:

      sudo apt-get install git gettext python-mako python-mutagen python-requests python-lxml glib-2.0

      • Agora Deu o erro:

        O pacote git não está disponível, mas é referenciado por outro pacote.
        Isto pode significar que o pacote está faltando, ficou obsoleto ou
        está disponível somente a partir de outra fonte
        E: O pacote git não tem candidato para instalação
        thiago@thiago-laptop:~$ git clone https://github.com/fossfreedom/coverart-browser -b master
        fatal: destination path ‘coverart-browser’ already exists and is not an empty directory.
        thiago@thiago-laptop:~$ cd coverart-browser
        thiago@thiago-laptop:~/coverart-browser$ sh ./install.sh
        installing languages to /usr/share/locale/
        installing az
        installing bg
        installing ca
        installing de
        installing en_GB
        installing en_US
        en_US.po:13: campo `Language-Team’ ainda possui o valor inicial
        installing es
        installing eu
        installing fi
        installing fr
        fr.po:13: campo `Language-Team’ ainda possui o valor inicial
        installing fr_CA
        installing gl
        installing he
        installing it
        installing ja
        installing lv
        installing ms
        installing pl
        installing pt_BR
        installing ru
        installing tr
        installing uz
        installing zh_CN
        installing zh_TW
        Installing the glib schema (password needed)
        cp: não foi possível criar arquivo comum `/usr/share/glib-2.0/schemas/’: É um diretório
        sudo: glib-compile-schemas: command not found

      • Certo cara, faa o seguinte: repita o comando que eu lhe indiquei mas sem o git. Antes de voc tentar instalar novamente, remova a pasta criada com os arquivos do coverart-browser.

    • Sim, mas eu no me referia ao comando de baixar e sim ao de instalar as dependncias. Como voc j tem o git (tanto que j baixou a pasta) no e necessrio colocar ele junto com os outros pacotes, j que e ele que est dando problema. Se quiser, experimente baixar pela prpria pgina do projeto no github. O que importa e que na hora de executar o script de instalao, voc tenha todas as dependncias instaladas.

      • Uhmmmm. E cara, isso pode ser um problema. Esse puglin, foi feito pro rhythmbox j aps o port pra gtk3 (que foi feito depois d 11.04, se no me engano. Por isso esses problemas com as dependncias. Voc tem algo que te impessa de atualizar, pra verses mais recentes do Ubuntu?

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s